[IPST-MicroBOX] with Arduino 1.05

ใช้งาน IPST-MicroBOX ด้วยซอฟต์แวร์ Arduino พร้อมการดาวน์โหลดผ่าน PX-4000

 บทความก่อนหน้านี้ แนะนำวิธีการใช้งาน ซอฟต์แวร์ Wiring กับบอร์ด IPST-MicroBOX ไป ผลตอบรับก็มีระดับนึงครับ แต่มีคนใช้งาน Arduino จำนวนมาก อยากให้ IPST-MicroBOX ใช้งานได้กับ Arduino บ้าง  มาลองดูกันเลยครับ

 IPST-MicroBOX ( IPST++ )หรือ IPST-SE ใช้งาน Arduino ได้

ก่อนอื่น ต้องไปดาวน์โหลดซอฟต์แวร์ Arduino เวอร์ชั่นที่รองรับ IPST++ กันก่อน ที่นี่ ครับ  หรือถ้าใครมี DVD หรือ CDROM ของ inex เวอร์ชั่นตั้งแต่เดือนตุลาคมเป็นต้นมา ก็จะมีซอฟต์แวร์ ArduinoIPST_SE_1.0.5_Setup130819.exe อยู่ในแผ่นให้ติดตั้งได้เลยครับ

 

แผ่น DVD รวมโปรแกรมของ inex

 

หลังจากนั้นก็ติดตั้งโปรแกรมตามขั้นตอนปกติ สำคัญตอนเลือกบอร์ด ถ้าใช้ IPST-MicroBOX อยู่ก็ให้เลือก Tools> Board > IPST-PlusPlus , ATMega16 @ 16MHz

 

เลือกบอร์ดที่ต้องการใช้งานจากเมนู Tools

ตอนนี้ก็สามารถเขียนโปรแกรม โดยใช้ซอฟต์แวร์ Arduino ได้แล้ว โดยบรรทัดบนสุด อย่าลืม

#include ไว้ด้วยนะครับ

 การดาวน์โหลดโปรแกรมผ่านเครื่องโปรแกรม PX-4000

ซอฟต์แวร์ Arduino ไม่มีคำสั่ง Build เหมือน Wiring ดังนั้นถ้าต้องการไฟล์ hex ไปใช้งานกับโปรแกรม AVRProg ต้องมีวิธีการพิเศษดังนี้

1. เปิดหน้าต่าง Preferences โดยไปที่  File > Preferences

 

เปิดหน้าต่าง Preferences เพื่อปรับเปลี่ยนการตั้งค่า

2.  เลือก ติ๊กที่ compilation เพื่อให้โปรแกรมแสดงขั้นตอนการคอมไพล์ เพราะเราจะใช้ขั้นตอนนี้ระบุตำแหน่งไฟล์ .hex ที่ใช้กับเครื่องโปรแกรม PX-4000

เปลี่ยนให้โปรแกรมแสดงขั้นตอนการคอมไพล์

3. ทดสอบเขียนโปรแกรมไฟกะพริบที่พอร์ต RB4

 #include <ipst.h> // include file for IPST-SE

void setup(){
}
void loop()
{
  out_b(4,1);
  sleep(300);
  out_b(4,0);
  sleep(300);
}

4. กดปุ่ม Verify (Ctrl + R ) เพื่อคอมไพล์โค้ดให้ได้เป็น Hex โค้ดออกมา

5. หน้าต่างด้านล่างจะแสดงขั้นตอนการคอมไพล์โค้ด ถ้าไม่มีอะไรผิดพลาด จะขึ้นข้อความ Done Compliling และบรรทัดก่อนบรรทัดล่างสุดจะระบุตำแหน่งของไฟล์ hex ที่ได้จากการคอมไพล์เอาไว้  ให้ทำแถบแล้วใช้คีย์ลัด CTRL+C คัดลอกเอาไว้

เมื่อคอมไพล์เรียบร้อย โปรแกรมจะแสดงชื่อไฟล์ .hex ออกมา

5. เชื่อมต่อบอร์ด PX-4000 เข้ากับ IPST-MicroBOX

เสียบเครื่องโปรแกรม PX-4000 เข้ากับ IPST++

6. จากนั้นเปิดโปรแกรม AVRProg ขึ้นมา ให้กดปุ่ม  Browse

เลือกไฟล์ที่ต้องการโปรแกรมจากตำแหน่งที่ระบุใน Arduino 1.05

7. ที่หน้าต่างสำหรับกำหนดตำแหน่งไฟล์ ให้กด CTRL+V เพื่อ วางตำแหน่งของ File ที่คัดลอกไว้

วางตำแหน่งของไฟล์ Hex ให้กับโปรแกรม AVRProg

8. กด Program ที่ AVRProg  ดูผลเลยว่าโปรแกรมทำงานถูกต้องหรือเปล่า

โปรแกรมไฟล์ Hex ไปยัง IPST++

ขั้นตอนอาจจะดูยุ่งยากเล็กน้อยสำหรับการใช้งานซอฟต์แวร์ Arduino  หวังว่าคงสามารถเอาบอร์ด IPST-MicroBOX ไปใช้งานได้หลากหลายมากขึ้นนะครับ

Facebook Comments